M1 Macs require either Java 16 or an  ARM-specific version of Java. If you have Java 16 installed on your M1 Mac, then you will need to be running FlowLogic 8.4.


Java 16 from Oracle can be downloaded from here: https://www.oracle.com/au/java/technologies/javase-downloads.html 


If you are running an older version of FlowLogic, then you can download an Open JDK version, modified by Azul for the ARM architecture of the M1 chips. You can download it from here: https://www.azul.com/downloads/zulu-community/?package=jdk%C2%A0 


We recommend running the Zulu: 15.29.15 ARM 64-bit JDK for macOS 11.0 or later:

Screen Shot 2021-02-18 at 12.20.38 am.png


Please consult your own IT department for information specific to your institute or company.